Information Exposure Affecting mediawiki/core Open this link in a new tab package, versions >=0.0.0


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-MEDIAWIKICORE-2806347

  • published

    1 May 2022

  • disclosed

    1 May 2022

  • credit

    Unknown

How to fix?

A fix was pushed into the master branch but not yet published.

Overview

mediawiki/core is a Free software wiki application developed by the Wikimedia Foundation and others.

Note: This package is not maintained on Packagist anymore, but newer releases exist.

Affected versions of this package are vulnerable to Information Exposure via the SecurePoll extension which allows a leak because sorting by timestamp is supported.