Improper Privilege Management Affecting bubblewrap package, versions <0:0.12.0-1.hum1


Severity

Recommended
0.0
high
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.27% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-BUBBLEWRAP-19934143
  • published19 Sept 2026
  • disclosed9 May 2026

Introduced: 9 May 2026

CVE-2026-41163  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade RHEL:10 bubblewrap to version 0:0.12.0-1.hum1 or higher.
This issue was patched in RHSA-2026:60368.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bubblewrap package and not the bubblewrap package as distributed by RHEL. See How to fix? for RHEL:10 relevant fixed versions and status.

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

CVSS Base Scores

version 3.1