CVE-2025-15444 Affecting libsodium package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-LIBSODIUM-14891759
  • published7 Jan 2026
  • disclosed1 Jan 2025

Introduced: 1 Jan 2025

CVE-2025-15444  (opens in a new tab)
CWE-1395  (opens in a new tab)

How to fix?

There is no fixed version for RHEL:10 libsodium.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsodium package and not the libsodium package as distributed by RHEL. See How to fix? for RHEL:10 relevant fixed versions and status.

Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium

libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277  https://www.cve.org/CVERecord?id=CVE-2025-69277 .

The libsodium vulnerability states:

In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.

0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.

CVSS Base Scores

version 3.1