Unchecked Return Value The advisory has been revoked - it doesn't affect any version of package mod_security  (opens in a new tab)


Threat Intelligence

EPSS
0.33% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-MODSECURITY-13175632
  • published1 Oct 2025
  • disclosed5 Aug 2025

Introduced: 5 Aug 2025

CVE-2025-54571  (opens in a new tab)
CWE-252  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mod_security package and not the mod_security package as distributed by RHEL.

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.