Cross-site Scripting (XSS) Affecting rabbitmq-server4.2 package, versions <0:4.2.8-1.hum1


Severity

Recommended
0.0
medium
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.25% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-RABBITMQSERVER42-18382386
  • published29 Jul 2026
  • disclosed10 Jul 2026

Introduced: 10 Jul 2026

CVE-2026-57213  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade RHEL:10 rabbitmq-server4.2 to version 0:4.2.8-1.hum1 or higher.
This issue was patched in RHSA-2026:35940.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rabbitmq-server4.2 package and not the rabbitmq-server4.2 package as distributed by RHEL. See How to fix? for RHEL:10 relevant fixed versions and status.

RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_federation_management plugin renders the consumer_tag field on the Federation Status page without HTML escaping, allowing a user who can configure a federation upstream or policy to execute JavaScript in the browser of a user viewing that page. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.

CVSS Base Scores

version 3.1