Improper Verification of Cryptographic Signature The advisory has been revoked - it doesn't affect any version of package ruby193-rubygems.src  (opens in a new tab)


Threat Intelligence

EPSS
0.93% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-RUBY193RUBYGEMSSRC-14922816
  • published14 Jan 2026
  • disclosed15 Feb 2018

Introduced: 15 Feb 2018

CVE-2018-1000076  (opens in a new tab)
CWE-347  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby193-rubygems.src package and not the ruby193-rubygems.src package as distributed by RHEL.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.