Improper Cross-boundary Removal of Sensitive Data The advisory has been revoked - it doesn't affect any version of package ruby-bundled-gems-debuginfo  (opens in a new tab)


Threat Intelligence

EPSS
0.56% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-RUBYBUNDLEDGEMSDEBUGINFO-14851068
  • published3 Jan 2026
  • disclosed30 Dec 2025

Introduced: 30 Dec 2025

CVE-2025-61594  (opens in a new tab)
CWE-212  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-bundled-gems-debuginfo package and not the ruby-bundled-gems-debuginfo package as distributed by RHEL.

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.