Cross-site Scripting (XSS) The advisory has been revoked - it doesn't affect any version of package satellite:el8/rubygem-rails-html-sanitizer-satellite:el8  (opens in a new tab)


Threat Intelligence

EPSS
0.45% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-SATELLITE-12594521
  • published10 Sept 2025
  • disclosed2 Dec 2024

Introduced: 2 Dec 2024

CVE-2024-53988  (opens in a new tab)
CWE-79  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream satellite:el8/rubygem-rails-html-sanitizer-satellite:el8 package and not the satellite:el8/rubygem-rails-html-sanitizer-satellite:el8 package as distributed by RHEL.

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the "math", "mtext", "table", and "style" elements are allowed and either either "mglyph" or "malignmark" are allowed. This vulnerability is fixed in 1.6.1.