Cross-site Scripting (XSS) The advisory has been revoked - it doesn't affect any version of package tfm-rubygem-rails-html-sanitizer  (opens in a new tab)


Threat Intelligence

EPSS
0.93% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-TFMRUBYGEMRAILSHTMLSANITIZER-13512797
  • published10 Oct 2025
  • disclosed13 Dec 2022

Introduced: 13 Dec 2022

CVE-2022-23518  (opens in a new tab)
CWE-79  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tfm-rubygem-rails-html-sanitizer package and not the tfm-rubygem-rails-html-sanitizer package as distributed by RHEL.

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Versions >= 1.0.3, < 1.4.4 are vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0. This issue is patched in version 1.4.4.