Directory Traversal Affecting tomcat5 package, versions <0:5.5.23-0jpp_12rh


Severity

Recommended
0.0
medium
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
99.71% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL10-TOMCAT5-9878785
  • published28 Apr 2025
  • disclosed11 Aug 2008

Introduced: 11 Aug 2008

CVE-2008-2938  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade RHEL:10 tomcat5 to version 0:5.5.23-0jpp_12rh or higher.
This issue was patched in RHSA-2008:0864.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat5 package and not the tomcat5 package as distributed by RHEL. See How to fix? for RHEL:10 relevant fixed versions and status.

Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking and UTF-8 are enabled, allows remote attackers to read arbitrary files via encoded directory traversal sequences in the URI, a different vulnerability than CVE-2008-2370. NOTE: versions earlier than 6.0.18 were reported affected, but the vendor advisory lists 6.0.16 as the last affected version.

References

CVSS Base Scores

version 3.1