Information Exposure Affecting camel-core package, versions *


Severity

Recommended
0.0
low
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.7% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-CAMELCORE-6277254
  • published26 Feb 2024
  • disclosed23 Feb 2024

Introduced: 23 Feb 2024

CVE-2024-22371  (opens in a new tab)
CWE-201  (opens in a new tab)

How to fix?

There is no fixed version for RHEL:7 camel-core.

NVD Description

Note: Versions mentioned in the description apply only to the upstream camel-core package and not the camel-core package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0.

Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

CVSS Base Scores

version 3.1