Out-of-bounds Write The advisory has been revoked - it doesn't affect any version of package commons-configuration  (opens in a new tab)


Threat Intelligence

EPSS
2.05% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-COMMONSCONFIGURATION-6475529
  • published21 Mar 2024
  • disclosed20 Mar 2024

Introduced: 20 Mar 2024

CVE-2024-29131  (opens in a new tab)
CWE-787  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:7.

NVD Description

Note: Versions mentioned in the description apply only to the upstream commons-configuration package and not the commons-configuration package as distributed by RHEL.

Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.

Users are recommended to upgrade to version 2.10.1, which fixes the issue.