Buffer Overflow The advisory has been revoked - it doesn't affect any version of package jbcs-httpd24-mod_ssl  (opens in a new tab)


Threat Intelligence

EPSS
1.02% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-JBCSHTTPD24MODSSL-18597018
  • published8 Aug 2026
  • disclosed8 Jun 2026

Introduced: 8 Jun 2026

CVE-2026-42536  (opens in a new tab)
CWE-120  (opens in a new tab)

Amendment

The Red Hat security team deemed this advisory irrelevant for RHEL:7.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jbcs-httpd24-mod_ssl package and not the jbcs-httpd24-mod_ssl package as distributed by RHEL.

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content

This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

Users are recommended to upgrade to version 2.4.68, which fixes the issue.