Out-of-bounds Write Affecting mesa-libGLw package, versions <0:8.0.0-5.el7


Severity

Recommended
medium

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
4.21% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-MESALIBGLW-8008825
  • published17 Sept 2024
  • disclosed21 Aug 2018

Introduced: 21 Aug 2018

CVE-2018-14599  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade RHEL:7 mesa-libGLw to version 0:8.0.0-5.el7 or higher.
This issue was patched in RHSA-2019:2079.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mesa-libGLw package and not the mesa-libGLw package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

An issue was discovered in libX11 through 1.6.5. The function XListExtensions in ListExt.c is vulnerable to an off-by-one error caused by malicious server responses, leading to DoS or possibly unspecified other impact.

CVSS Base Scores

version 3.1