Directory Traversal Affecting openwsman-perl package, versions <0:2.6.3-6.git4391e5c.el7_6


Severity

Recommended
0.0
high
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
14.74% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-OPENWSMANPERL-4842296
  • published26 Jul 2021
  • disclosed12 Mar 2019

Introduced: 12 Mar 2019

CVE-2019-3816  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade RHEL:7 openwsman-perl to version 0:2.6.3-6.git4391e5c.el7_6 or higher.
This issue was patched in RHSA-2019:0638.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openwsman-perl package and not the openwsman-perl package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

Openwsman, versions up to and including 2.6.9, are vulnerable to arbitrary file disclosure because the working directory of openwsmand daemon was set to root directory. A remote, unauthenticated attacker can exploit this vulnerability by sending a specially crafted HTTP request to openwsman server.

CVSS Base Scores

version 3.1