Cross-site Scripting (XSS) Affecting satellite:el8/rubygem-rails-html-sanitizer package, versions *


Severity

Recommended
0.0
low
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.45% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-SATELLITE-8452254
  • published3 Dec 2024
  • disclosed2 Dec 2024

Introduced: 2 Dec 2024

CVE-2024-53987  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for RHEL:7 satellite:el8/rubygem-rails-html-sanitizer.

NVD Description

Note: Versions mentioned in the description apply only to the upstream satellite:el8/rubygem-rails-html-sanitizer package and not the satellite:el8/rubygem-rails-html-sanitizer package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. There is a possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer 1.6.0 when used with Rails >= 7.1.0. A possible XSS vulnerability with certain configurations of Rails::HTML::Sanitizer may allow an attacker to inject content if HTML5 sanitization is enabled and the application developer has overridden the sanitizer's allowed tags where the "style" element is explicitly allowed and the "svg" or "math" element is not allowed. This vulnerability is fixed in 1.6.1.

CVSS Base Scores

version 3.1