Out-of-bounds Write Affecting webkitgtk4-devel package, versions *


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 0.14% (50th percentile)
Expand this section
NVD
8.8 high
Expand this section
Red Hat
8.8 high
Expand this section
SUSE
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RHEL7-WEBKITGTK4DEVEL-6101887
  • published 6 Dec 2023
  • disclosed 5 Dec 2023

How to fix?

There is no fixed version for RHEL:7 webkitgtk4-devel.

NVD Description

Note: Versions mentioned in the description apply only to the upstream webkitgtk4-devel package and not the webkitgtk4-devel package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

A memory corruption vulnerability was addressed with improved locking. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari 17.1.2. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been exploited against versions of iOS before iOS 16.7.1.