Improper Input Validation Affecting webkitgtk4-jsc-devel package, versions *


0.0
medium

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Availability High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 0.11% (44th percentile)
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
6.8 medium
Expand this section
SUSE
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RHEL7-WEBKITGTK4JSCDEVEL-6101877
  • published 6 Dec 2023
  • disclosed 1 Dec 2023

How to fix?

There is no fixed version for RHEL:7 webkitgtk4-jsc-devel.

NVD Description

Note: Versions mentioned in the description apply only to the upstream webkitgtk4-jsc-devel package and not the webkitgtk4-jsc-devel package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

An out-of-bounds read was addressed with improved input validation. This issue is fixed in iOS 17.1.2 and iPadOS 17.1.2, macOS Sonoma 14.1.2, Safari 17.1.2. Processing web content may disclose sensitive information. Apple is aware of a report that this issue may have been exploited against versions of iOS before iOS 16.7.1.