Improper Authorization Affecting openstack-selinux package, versions <0:0.8.24-1.20200914163011.26243bf.el8ost


Severity

Recommended
0.0
medium
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL8-OPENSTACKSELINUX-4374185
  • published26 Mar 2023
  • disclosed12 Feb 2020

Introduced: 12 Feb 2020

CVE-2020-1690  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade RHEL:8 openstack-selinux to version 0:0.8.24-1.20200914163011.26243bf.el8ost or higher.
This issue was patched in RHSA-2020:4381.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openstack-selinux package and not the openstack-selinux package as distributed by RHEL. See How to fix? for RHEL:8 relevant fixed versions and status.

An improper authorization flaw was discovered in openstack-selinux's applied policy where it does not prevent a non-root user in a container from privilege escalation. A non-root attacker in one or more Red Hat OpenStack (RHOSP) containers could send messages to the dbus. With access to the dbus, the attacker could start or stop services, possibly causing a denial of service. Versions before openstack-selinux 0.8.24 are affected.

CVSS Base Scores

version 3.1