Resource Exhaustion Affecting pacemaker-cli package, versions <0:2.0.1-4.el8_0.3


Severity

Recommended
high

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
0.41% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL8-PACEMAKERCLI-3420958
  • published26 Jul 2021
  • disclosed17 Apr 2019

Introduced: 17 Apr 2019

CVE-2018-16878  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade RHEL:8 pacemaker-cli to version 0:2.0.1-4.el8_0.3 or higher.
This issue was patched in RHSA-2019:1279.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker-cli package and not the pacemaker-cli package as distributed by RHEL. See How to fix? for RHEL:8 relevant fixed versions and status.

A flaw was found in pacemaker up to and including version 2.0.1. An insufficient verification inflicted preference of uncontrolled processes can lead to DoS

CVSS Base Scores

version 3.1