Improper Input Validation Affecting rhvm-appliance package, versions <2:4.4-20210310.0.el8ev


Severity

Recommended
medium

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
2.23% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL8-RHVMAPPLIANCE-5354747
  • published26 Jul 2021
  • disclosed13 Aug 2020

Introduced: 13 Aug 2020

CVE-2020-14349  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade RHEL:8 rhvm-appliance to version 2:4.4-20210310.0.el8ev or higher.
This issue was patched in RHSA-2021:0988.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rhvm-appliance package and not the rhvm-appliance package as distributed by RHEL. See How to fix? for RHEL:8 relevant fixed versions and status.

It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.

CVSS Base Scores

version 3.1