Double Free Affecting ruby:3.0/rubygem-mysql2 package, versions <0:0.5.3-1.module+el8.5.0+11580+845038eb


Severity

Recommended
medium

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
3.14% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL8-RUBY-4351415
  • published15 Apr 2022
  • disclosed14 Apr 2022

Introduced: 14 Apr 2022

CVE-2022-28738  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade RHEL:8 ruby:3.0/rubygem-mysql2 to version 0:0.5.3-1.module+el8.5.0+11580+845038eb or higher.
This issue was patched in RHSA-2022:6450.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby:3.0/rubygem-mysql2 package and not the ruby:3.0/rubygem-mysql2 package as distributed by RHEL. See How to fix? for RHEL:8 relevant fixed versions and status.

A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.

CVSS Base Scores

version 3.1