Missing Authentication for Critical Function Affecting httpd-tools package, versions <0:2.4.63-13.el10_2.8


Severity

Recommended
high

Based on Rocky Linux security rating.

Threat Intelligence

EPSS
0.56% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ROCKY10-HTTPDTOOLS-21760946
  • published28 Oct 2026
  • disclosed1 Oct 2026

Introduced: 1 Oct 2026

NewCVE-2026-48005  (opens in a new tab)
CWE-306  (opens in a new tab)

How to fix?

Upgrade Rocky-Linux:10 httpd-tools to version 0:2.4.63-13.el10_2.8 or higher.
This issue was patched in RLSA-2026:89860.

NVD Description

Note: Versions mentioned in the description apply only to the upstream httpd-tools package and not the httpd-tools package as distributed by Rocky-Linux. See How to fix? for Rocky-Linux:10 relevant fixed versions and status.

Missing authentication checks in mod_auth_digest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause a denial of service (forced re-authentication) via forged Authorization headers when Digest authentication is enabled with AuthDigestNcCheck .

Users are recommended to upgrade to version 2.4.69, which fixes this issue.

CVSS Base Scores

version 3.1