CVE-2023-40403 Affecting libxslt-debugsource package, versions <0:1.1.32-6.2.el8_10


Severity

Recommended
0.0
medium
0
10

Based on Rocky Linux security rating.

Threat Intelligence

EPSS
1.33% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-ROCKY8-LIBXSLTDEBUGSOURCE-11333000
  • published30 Jul 2025
  • disclosed27 Sept 2023

Introduced: 27 Sep 2023

CVE-2023-40403  (opens in a new tab)

How to fix?

Upgrade Rocky-Linux:8 libxslt-debugsource to version 0:1.1.32-6.2.el8_10 or higher.
This issue was patched in RLSA-2025:8676.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxslt-debugsource package and not the libxslt-debugsource package as distributed by Rocky-Linux. See How to fix? for Rocky-Linux:8 relevant fixed versions and status.

The issue was addressed with improved memory handling. This issue is fixed in macOS Ventura 13.6, tvOS 17, iOS 16.7 and iPadOS 16.7, macOS Monterey 12.7, watchOS 10, iOS 17 and iPadOS 17, macOS Sonoma 14. Processing web content may disclose sensitive information.

CVSS Base Scores

version 3.1