Link Following Affecting cups package, versions <1.5.3-0ubuntu8.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-CUPS-364347
  • published29 Jul 2014
  • disclosed29 Jul 2014

Introduced: 29 Jul 2014

CVE-2014-5030  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 cups to version 1.5.3-0ubuntu8.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

CUPS before 2.0 allows local users to read arbitrary files via a symlink attack on (1) index.html, (2) index.class, (3) index.pl, (4) index.php, (5) index.pyc, or (6) index.py.

CVSS Base Scores

version 3.1