Out-of-Bounds Affecting cups package, versions <1.5.3-0ubuntu8.6


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.63% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-CUPS-364382
  • published19 Feb 2015
  • disclosed19 Feb 2015

Introduced: 19 Feb 2015

CVE-2014-9679  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 cups to version 1.5.3-0ubuntu8.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Integer underflow in the cupsRasterReadPixels function in filter/raster.c in CUPS before 2.0.2 allows remote attackers to have unspecified impact via a malformed compressed raster file, which triggers a buffer overflow.

CVSS Base Scores

version 3.1