Improper Input Validation Affecting distribute package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.97% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-DISTRIBUTE-262253
  • published6 Aug 2013
  • disclosed6 Aug 2013

Introduced: 6 Aug 2013

CVE-2013-1633  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:12.04 distribute.

NVD Description

Note: Versions mentioned in the description apply only to the upstream distribute package and not the distribute package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

easy_install in setuptools before 0.7 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to the default use of the product.

CVSS Base Scores

version 3.1