Arbitrary Code Injection Affecting djvulibre package, versions <3.5.24-9ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.64% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-DJVULIBRE-266713
  • published2 Dec 2013
  • disclosed2 Dec 2013

Introduced: 2 Dec 2013

CVE-2012-6535  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 djvulibre to version 3.5.24-9ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream djvulibre package and not the djvulibre package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

DjVuLibre before 3.5.25.3, as used in Evince, Sumatra PDF Reader, VuDroid, and other products, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted DjVu (aka .djv) file.

CVSS Base Scores

version 3.1