Out-of-Bounds Affecting dosfstools package, versions <3.0.12-1ubuntu1.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-DOSFSTOOLS-320249
  • published3 Jun 2016
  • disclosed3 Jun 2016

Introduced: 3 Jun 2016

CVE-2016-4804  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 dosfstools to version 3.0.12-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dosfstools package and not the dosfstools package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The read_boot function in boot.c in dosfstools before 4.0 allows attackers to cause a denial of service (crash) via a crafted filesystem, which triggers a heap-based buffer overflow in the (1) read_fat function or an out-of-bounds heap read in (2) get_fat function.

CVSS Base Scores

version 3.1