Improper Data Handling Affecting dulwich package, versions <0.8.5-2+deb7u2build0.12.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-DULWICH-285200
  • published31 Mar 2015
  • disclosed31 Mar 2015

Introduced: 31 Mar 2015

CVE-2014-9706  (opens in a new tab)
CWE-19  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 dulwich to version 0.8.5-2+deb7u2build0.12.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dulwich package and not the dulwich package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The build_index_from_tree function in index.py in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a commit with a directory path starting with .git/, which is not properly handled when checking out a working tree.

CVSS Base Scores

version 3.1