Out-of-Bounds Affecting dulwich package, versions <0.8.5-2+deb7u2build0.12.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.38% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-DULWICH-285214
  • published31 Mar 2015
  • disclosed31 Mar 2015

Introduced: 31 Mar 2015

CVE-2015-0838  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 dulwich to version 0.8.5-2+deb7u2build0.12.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dulwich package and not the dulwich package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Buffer overflow in the C implementation of the apply_delta function in _pack.c in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a crafted pack file.

CVSS Base Scores

version 3.1