Information Exposure Affecting evolution-data-server package, versions <3.2.3-0ubuntu7.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.89% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-EVOLUTIONDATASERVER-289598
  • published27 Jun 2018
  • disclosed6 Feb 2020

Introduced: 27 Jun 2018

CVE-2013-4166  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 evolution-data-server to version 3.2.3-0ubuntu7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evolution-data-server package and not the evolution-data-server package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The gpg_ctx_add_recipient function in camel/camel-gpg-context.c in GNOME Evolution 3.8.4 and earlier and Evolution Data Server 3.9.5 and earlier does not properly select the GPG key to use for email encryption, which might cause the email to be encrypted with the wrong key and allow remote attackers to obtain sensitive information.

CVSS Base Scores

version 3.1