Improper Certificate Validation Affecting fence-agents package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.83% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-FENCEAGENTS-285796
  • published27 Jun 2018
  • disclosed2 Jan 2020

Introduced: 27 Jun 2018

CVE-2014-0104  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:12.04 fence-agents.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fence-agents package and not the fence-agents package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

CVSS Base Scores

version 3.1