Out-of-Bounds Affecting gdk-pixbuf package, versions <2.26.1-1ubuntu1.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.87% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-GDKPIXBUF-344925
  • published18 Apr 2016
  • disclosed18 Apr 2016

Introduced: 18 Apr 2016

CVE-2015-7552  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 gdk-pixbuf to version 2.26.1-1ubuntu1.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdk-pixbuf package and not the gdk-pixbuf package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Heap-based buffer overflow in the gdk_pixbuf_flip function in gdk-pixbuf-scale.c in gdk-pixbuf 2.30.x allows remote attackers to cause a denial of service or possibly execute arbitrary code via a crafted BMP file.