Out-of-Bounds Affecting gdk-pixbuf package, versions <2.26.1-1ubuntu1.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.45% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-GDKPIXBUF-345028
  • published26 Oct 2015
  • disclosed26 Oct 2015

Introduced: 26 Oct 2015

CVE-2015-7673  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 gdk-pixbuf to version 2.26.1-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdk-pixbuf package and not the gdk-pixbuf package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

io-tga.c in gdk-pixbuf before 2.32.0 uses heap memory after its allocation failed, which allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) and possibly execute arbitrary code via a crafted Truevision TGA (TARGA) file.

CVSS Base Scores

version 3.1