Information Exposure Affecting glance package, versions <2012.1.3+stable~20120821-120fcf-0ubuntu1.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.37% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-GLANCE-313230
  • published22 Mar 2013
  • disclosed22 Mar 2013

Introduced: 22 Mar 2013

CVE-2013-1840  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 glance to version 2012.1.3+stable~20120821-120fcf-0ubuntu1.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The v1 API in OpenStack Glance Essex (2012.1), Folsom (2012.2), and Grizzly, when using the single-tenant Swift or S3 store, reports the location field, which allows remote authenticated users to obtain the operator's backend credentials via a request for a cached image.

CVSS Base Scores

version 3.1