Cryptographic Issues Affecting gnome-online-accounts package, versions <3.4.0-0ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.36% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-GNOMEONLINEACCOUNTS-278358
  • published2 Apr 2013
  • disclosed2 Apr 2013

Introduced: 2 Apr 2013

CVE-2013-0240  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 gnome-online-accounts to version 3.4.0-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-online-accounts package and not the gnome-online-accounts package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Gnome Online Accounts (GOA) 3.4.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.5, does not properly validate SSL certificates when creating accounts such as Windows Live and Facebook accounts, which allows man-in-the-middle attackers to obtain sensitive information such as credentials by sniffing the network.

CVSS Base Scores

version 3.1