Improper Input Validation Affecting gpsd package, versions <3.4-2ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.15% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-GPSD-310522
  • published6 Feb 2014
  • disclosed6 Feb 2014

Introduced: 6 Feb 2014

CVE-2013-2038  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 gpsd to version 3.4-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gpsd package and not the gpsd package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The NMEA0183 driver in gpsd before 3.9 allows remote attackers to cause a denial of service (daemon termination) and possibly execute arbitrary code via a GPS packet with a malformed $GPGGA interpreted sentence that lacks certain fields and a terminator. NOTE: a separate issue in the AIS driver was also reported, but it might not be a vulnerability.

CVSS Base Scores

version 3.1