Resource Management Errors Affecting isc-dhcp package, versions <4.1.ESV-R4-0ubuntu5.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.33% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-ISCDHCP-382218
  • published25 Jul 2012
  • disclosed25 Jul 2012

Introduced: 25 Jul 2012

CVE-2012-3954  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 isc-dhcp to version 4.1.ESV-R4-0ubuntu5.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream isc-dhcp package and not the isc-dhcp package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Multiple memory leaks in ISC DHCP 4.1.x and 4.2.x before 4.2.4-P1 and 4.1-ESV before 4.1-ESV-R6 allow remote attackers to cause a denial of service (memory consumption) by sending many requests.

CVSS Base Scores

version 3.1