Race Condition Affecting kde4libs package, versions <4:4.8.5-0ubuntu0.4


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-KDE4LIBS-331219
  • published19 Aug 2014
  • disclosed19 Aug 2014

Introduced: 19 Aug 2014

CVE-2014-5033  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 kde4libs to version 4:4.8.5-0ubuntu0.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kde4libs package and not the kde4libs package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

KDE kdelibs before 4.14 and kauth before 5.1 does not properly use D-Bus for communication with a polkit authority, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process, related to CVE-2013-4288 and "PID reuse race conditions."

CVSS Base Scores

version 3.1