Cleartext Transmission of Sensitive Information Affecting kde4libs package, versions <4:4.8.5-0ubuntu0.6


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.86% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-KDE4LIBS-331225
  • published2 Mar 2017
  • disclosed2 Mar 2017

Introduced: 2 Mar 2017

CVE-2017-6410  (opens in a new tab)
CWE-319  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 kde4libs to version 4:4.8.5-0ubuntu0.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kde4libs package and not the kde4libs package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

kpac/script.cpp in KDE kio before 5.32 and kdelibs before 4.14.30 calls the PAC FindProxyForURL function with a full https URL (potentially including Basic Authentication credentials, a query string, or PATH_INFO), which allows remote attackers to obtain sensitive information via a crafted PAC file.