Directory Traversal Affecting kde4libs package, versions <4:4.8.5-0ubuntu0.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.43% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-KDE4LIBS-331233
  • published2 Aug 2016
  • disclosed2 Aug 2016

Introduced: 2 Aug 2016

CVE-2016-6232  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 kde4libs to version 4:4.8.5-0ubuntu0.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kde4libs package and not the kde4libs package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Directory traversal vulnerability in KArchive before 5.24, as used in KDE Frameworks, allows remote attackers to write to arbitrary files via a ../ (dot dot slash) in a filename in an archive file, related to KNewsstuff downloads.