Out-of-bounds Read Affecting libidn package, versions <1.23-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.88% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBIDN-311018
  • published7 Sept 2016
  • disclosed7 Sept 2016

Introduced: 7 Sep 2016

CVE-2016-6261  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libidn to version 1.23-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libidn package and not the libidn package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The idna_to_ascii_4i function in lib/idna.c in libidn before 1.33 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via 64 bytes of input.