Arbitrary Command Injection Affecting libmodule-signature-perl package, versions <0.68-1ubuntu0.12.04.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.62% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBMODULESIGNATUREPERL-306031
  • published19 May 2015
  • disclosed19 May 2015

Introduced: 19 May 2015

CVE-2015-3408  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libmodule-signature-perl to version 0.68-1ubuntu0.12.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmodule-signature-perl package and not the libmodule-signature-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Module::Signature before 0.74 allows remote attackers to execute arbitrary shell commands via a crafted SIGNATURE file which is not properly handled when generating checksums from a signed manifest.

CVSS Base Scores

version 3.1