Improper Input Validation Affecting libmodule-signature-perl package, versions <0.68-1ubuntu0.12.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.55% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBMODULESIGNATUREPERL-306055
  • published19 Aug 2013
  • disclosed19 Aug 2013

Introduced: 19 Aug 2013

CVE-2013-2145  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libmodule-signature-perl to version 0.68-1ubuntu0.12.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmodule-signature-perl package and not the libmodule-signature-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The cpansign verify functionality in the Module::Signature module before 0.72 for Perl allows attackers to bypass the signature check and execute arbitrary code via a SIGNATURE file with a "special unknown cipher" that references an untrusted module in Digest/.

CVSS Base Scores

version 3.1