Out-of-Bounds Affecting libx11 package, versions <2:1.4.99.1-0ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.58% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBX11-339096
  • published15 Jun 2013
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-2004  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libx11 to version 2:1.4.99.1-0ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libx11 package and not the libx11 package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The (1) GetDatabase and (2) _XimParseStringFile functions in X.org libX11 1.5.99.901 (1.6 RC1) and earlier do not restrict the recursion depth when processing directives to include files, which allows X servers to cause a denial of service (stack consumption) via a crafted file.

CVSS Base Scores

version 3.1