Numeric Errors Affecting libx11 package, versions <2:1.4.99.1-0ubuntu2.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.25% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBX11-339164
  • published16 Apr 2015
  • disclosed16 Apr 2015

Introduced: 16 Apr 2015

CVE-2013-7439  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libx11 to version 2:1.4.99.1-0ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libx11 package and not the libx11 package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Multiple off-by-one errors in the (1) MakeBigReq and (2) SetReqLen macros in include/X11/Xlibint.h in X11R6.x and libX11 before 1.6.0 allow remote attackers to have unspecified impact via a crafted request, which triggers a buffer overflow.

CVSS Base Scores

version 3.1