Out-of-Bounds Affecting libxi package, versions <2:1.6.0-0ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.8% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBXI-278782
  • published15 Jun 2013
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-1998  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libxi to version 2:1.6.0-0ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxi package and not the libxi package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Multiple buffer overflows in X.org libXi 1.7.1 and earlier allow X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the (1) XGetDeviceButtonMapping, (2) XIPassiveGrabDevice, and (3) XQueryDeviceState functions.

CVSS Base Scores

version 3.1