XML External Entity (XXE) Injection Affecting libxml-libxml-perl package, versions <1.89+dfsg-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.02% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBXMLLIBXMLPERL-313341
  • published12 May 2015
  • disclosed12 May 2015

Introduced: 12 May 2015

CVE-2015-3451  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libxml-libxml-perl to version 1.89+dfsg-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml-libxml-perl package and not the libxml-libxml-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.

CVSS Base Scores

version 3.1